Support DESK

Follow

Appendix B - Getting Started - Runtime Requirements

Previous Article matchIT Hub Index Next Article

An application that uses matchIT Hub requires various precompiled binary files depending on which API has been used. The following details these requirements.

Windows

In addition, the Microsoft Visual C++ 2015 runtime must be installed. Redistributable installers can be found in C:\Program Files\matchIT Hub\redist. Only the installer that corresponds to the architecture of the application (32- or 64-bit) must be installed.

C and C++

matchITHub.dll - All matchIT Hub functionality.

.NET

matchITHub.dll - All matchIT Hub functionality.

matchITHub_net4.dll - The .NET interface to matchIT Hub.

Java

matchITHub.dll - All matchIT Hub functionality.

matchITHub.jar - The Java interface to matchIT Hub.

Other languages (using SWIG)

matchITHub.dll - All matchIT Hub functionality.

Plus any wrapper built from the generated SWIG files (please refer to the SWIG documentation for details).

Other Operating Systems

Note that matchIT Hub has been compiled using GCC 5.2 and therefore requires glibc 2.21. A precompiled version of libstdc++.so can be provided upon request, although it is highly recommended that GCC 5.2 or greater is compiled and used on your platform.

C and C++

libmatchITHub.so - All matchIT Hub functionality.

Java

libmatchITHub.so - All matchIT Hub functionality.

matchITHub.jar - The Java interface to matchIT Hub.

Other languages (using SWIG)

matchITHub.so - All matchIT Hub functionality.

Plus any wrapper built from the generated SWIG files (please refer to the SWIG documentation for details).

Previous Article matchIT Hub Index Next Article
Was this article helpful?
0 out of 0 found this helpful

0 Comments

Please sign in to leave a comment.