Support DESK

Follow

Upgrading an SSIS package to a newer version of SQL Server:

 

SSIS packages created using SQL Server (2005-2014) cannot be automatically upgraded to a later version without first performing a pre-upgrade step. First, open the .dtsx package file in a text editor such as Notepad. Next, replace all instances of 9.0.0.0 (if created using SQL Server 2005), 10.0.0.0 (2008), or 11.0.0.0 (2012), or 12.0.0.0 (2014) with either 10.0.0.0 (if upgrading to SQL Server 2008), 11.0.0.0 (2012), or 12.0.0.0 (2014), or 13.0.0.0 (2016), 14.0.0.0 (2017) then save the modified file. Lastly, open the solution with BIDS (2008) or SQL Server Data Tools (2012/2017), which will automatically convert the solution and package.

Note that as of SQL Server 2014-2016, SQL Server Data Tools must be downloaded and installed separately; please refer to: http://www.microsoft.com/en-us/download/details.aspx?id=42313 (2014) or https://msdn.microsoft.com/en-us/library/mt204009.aspx (2016)

If you experience an error related to tasks not being registered for use on the PC when attempting to open the tasks, please check that the TargetServerVersion in the SSIS package is set correctly relevant to the version of SQL Server you are using.


If you need to downgrade a project - then please click here

Was this article helpful?
0 out of 0 found this helpful

0 Comments

Please sign in to leave a comment.